WordPress Vulnerability Check

WordPress Vulnerability Check (wp-vulnerability-check) is a console application to check the WPScan Vulnerability Database via API to identify the security issues of WordPress plugins installed.

Readme

Last 30 days:

1
Open issues
0
PRs opened
0
Contributors

Project type

First Timer FriendlyTools

Project tech

PHP

Currently seeking

  • Developers
  • Backend Developers

Contribution overview

The maintainers of this project have not provided a contribution overview.

Overview

WordPress Vulnerability Check (wp-vulnerability-check) is a console application to check the WPScan Vulnerability Database via API to identify the security issues of WordPress plugins installed.

If you're using WordPress as part of your application and third-party WordPress plugins to implement your business logic, you can run wp-vulnerability-check on a CI pipeline to check the vulnerabilities. You should get a token from wpscan.com in order to have access to the API.

Contributing

If you are reading this document then you are interested in contributing to wp-vulnerability-check, and that's awesome!

All contributions are welcome: use-cases, documentation, code, patches, bug reports, feature requests, etc. You do not need to be a programmer to speak up!